Results 1 to 2 of 2
  1. #1
    Join Date
    Dec 2005
    Location
    Mi lugar oscuro
    Posts
    8,875

    psa: ortovox 3+ recall for software version 2.1

    https://mailchi.mp/4e1d34d99e9b/prec...1?e=79ab641432

    WHICH TRANSCEIVERS ARE AFFECTED?
    This precautionary recall applies exclusively to ORTOVOX 3+ avalanche transceivers running software version 2.1. – no matter what color

    3+ devices running the following software: 1.0, 1.1, 2.0, 2.2 and all other ORTOVOX avalanche transceivers (S1+, S1, ZOOM) are not affected.
    山、川、森林、砂漠、海、空

  2. #2
    Join Date
    Dec 2004
    Posts
    9,218
    Fucking unbelievable that they cannot upgrade them in the US and need to be shipped to Ger.
    Quote Originally Posted by SkiCougar View Post
    thanks. I wasn't a racist until Obama, so I have to give him partial credit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •