Results 1 to 5 of 5
  1. #1
    Join Date
    Apr 2011

    Radical 2.0 heel failure/consistent pre-release

    I posted up in the Radical 2.0 thread but ongoing issues deserve another thread.

    Basically, I am having serious problems with the forward pressure spring. It does not do this consistently, but I have eventually been able to capture a few videos of everything that has been going on. I have had multiple pre-releases, written off at first to something icing up, then getting more and more worried.

    Video round 1, felt it "clicking" on the descent when the ski was flexed, caught this on video, then couldn't replicate 10 min later at the parking lot even with the ski flexed in soft snow.

    Round 2, on the bench:

    Round 3, new brake/forward pressure assembly. This was after stepping in, wasn't able to get it to go when clicked in and stomping, also haven't skied them much to try... *MAYBE* that is normal (?!?)—they are new brake towers and I haven't felt the same clicking when skiing. That said I have lost almost all confidence in these bindings, this doesn't look right to me at all, and I have no desire to keep testing what seems to be a serious problem.

    Local shop has been swamped with Dynafit warranties this winter it sounds like and doing their best, but Dynafit doesn't want to do anything for me because I'm skiing in Mountain Labs and not Dynafit certified boots, which is ridiculous.

    I should note that I had a friend spend a day on these in BD boots and reported multiple (2) pre-releases, and we checked before and after that forward pressure/spacing was correct. He generally skis on regular radical FTs and it was all soft snow touring, so not user error/resort conditions. Dynafit still says, "hey, not our fittings, not our problem." It was initially worse on one ski than the other, and so the shop just swapped one brake/forward pressure plate out before he tried them. Buddy thought that new heel track was the ski that was releasing, but cannot confirm 100%, as he wasn't thinking about it much at the time. I had assumed the issue was fixed and didn't mention it. That night on the bench I had a crazy experience adjusting things back to my boot where I was able to click in to the heel that had the new track/brake with maybe 1/2 the force it took to do the other ski/binding. Tried it about 3 times, same experience (no video of that). Can't repeat... maybe I am going insane, but that freaked me out as well. I was actually able to swap out the tower itself, so full "new" heel to test... one mellow pow day didn't notice anything, 2nd day on the new setup I am experiencing that hangup when clicking in (video 3). If that is normal, maybe I just got super unlucky with 2 bad heel tracks and a bad heel tower or brief demonic possession/psychotic episode.

    But.... based on the previous experience with these bindings I am pretty doubtful that is supposed to occur.

    I have found almost no complaints about these bindings online, and was more or less happy with speed radicals and original FTs, figured I would be a little less worried about coming out of the 2.0. Not the case.

    Anyone else experiencing issues? Am I the only one, plus the one other dude who posted before me on the main Radical 2.0 thread? Shop and buddy who is a guide both say they have seen way more dynafit problems than previous years, mostly stemming from heel pre-releases.

    Also really want to call bullshit on Dynafit for trying to blame Salomon and Black Diamond.

  2. #2
    Join Date
    Nov 2014
    A few weeks ago I was together with a guy who hired Dynafit skis (current 7Summit) and binding (Radical 2) - donīt remember which boots he had.
    Despite the binding was set properly, the third day he complained that he couldnīt step in one ski in and it turned out that the heel piece was way too far back, I mean 5-6mm too much.
    We set the distance to an approximately correct value and then the guy went straight to a shop to let check it - I wasnīt present

    2 days later the same guy fell while skiing over a rat track in a resort and broke his tibia because the binding didnīt release.
    I really cannot tell whether it was the same ski or the other one.
    Anyway, the binding wasnīt locked.
    Last edited by PNB; 03-17-2017 at 06:01 AM.

  3. #3
    Join Date
    Mar 2006
    Nottingham, UK
    deft_funk , definitely a problem with your Rad 2's there. I've sold a couple of hundred Rad 2's since their launch & the only issue I've had is a couple of busted sliding AFD plates.

    Should definitely be a warranty issue providing that the spring/captive nut mechanism is not catching on the top sheet of the ski so I'd recommend pulling the binding and checking for any burrs, either on the topsheet or on the captive nut. Also check that the captive nut is fully recessed within the base plate (when the binding is removed it tends to protrude a tad but should easily push in - if it doesn't then there's a problem). Might also be worth adjusting the binding length through its full range of adjustment to see if there's a burr/snag on the rail etc.

    After seeing & hearing of a number of BD boots with excess wear to their inserts I've stopped selling tech bindings to BD boot owners - of which there are actually very few in the UK as they weren't a strong brand. Can't see it a problem Dynafit not supporting BD boot use if they think their inserts are out of spec or are subject to excessive wear.

    According to my Dynafit rep, all Salomon tech boots for 16/17 have Dynafit supplied inserts in them. Some later production 15/16 boots also had some but there's no way to tell which they are. So if you have 16/17 Mtn Labs you should get full support from Dynafit.

  4. #4
    Join Date
    Apr 2011
    Spyderjon, I've actually tried them on two pairs of skis just to make sure nothing was catching as I thought of that as well. Super smooth old holes, and they are nowhere near the center channel where the spring is located. I have noticed the nut pushes out sometimes when the bindings are off, but it seems to go back in easily. My boots are 15/16, but I don't think that Dynafit ever asked about that, although possibly they did and the shop didn't relate that to me.

    Strange that your rep says new Salomon boots have Dynafit-provided inserts and our rep says I can fuck off. I did note that there is nowhere on the website that says you need to have Dynafit-certified tech fittings for them to honor warranty, shop is trying to get ahold of them again today.

    Also weird that you have seen no issues at all with them, shop here says they are totally swamped with Dynafit warranties this year. Maybe there was a bad batch. Surprised that there is no murmuring of discontent on TGR; maybe I just got super unlucky with two bad pairs of brake/heel units back to back.

  5. #5
    Join Date
    Sep 2020
    I know I'm late to this but I've had the exact problem with my ST Rotation 12 heels. I've replaced them under warranty and the problem reoccured. On both sets the problem began around the 15 day mark. Were you able to find a solution to the problem? A friend of mine had the same issue with the same binding, he took it back to the shop and they said it needed to be lubricated. They did this but he didn't get a chance to test them afterwards (COVID shutdown).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts