Page 140 of 140 FirstFirst ... 135 136 137 138 139 140
Results 3,476 to 3,488 of 3488
  1. #3476
    Join Date
    Feb 2010
    Posts
    660
    Originally Posted by PMRx View Post
    For the life of me I can't get my binding to sit flush on the ski. Trimmed the small volcano with a chisel. Sits flat until I get a couple of turns in then it lifts up just a touch. Can't keep it flush with finger strength, should I clamp it? Still seems like an indication something is up.

    Advice?

    QUOTE=LeoK;5862804]Advice: don't worry too much (at least if the gap is sub .5mm or so). Make sure to seal all screws properly.[/QUOTE]

    Not sure I agree with this.
    If it sat flush, then moved, it will move more. And, depending on how you ski, leverage on a tele binding can be considerable.

  2. #3477
    Join Date
    Sep 2004
    Location
    LV-426
    Posts
    16,094
    Quote Originally Posted by PMRx View Post
    Did not tap it. They are old Rosignol T3 Tele skis. Couldn't find much info. Looked like some metal when I drilled them.

    Mounting speed turns and it's just one heel piece that's a problem. Am I reading that maybe the threading on the heel piece is contributing?
    I had this problem with mounting Dynafits where the screws were tight in the bindings. I drilled out the interference in the bindings (making the screws fit normally like in every other binding) and they mounted much more easily.
    Quote Originally Posted by powder11 View Post
    if you have to resort to taking advice from the nitwits on this forum, then you're doomed.

  3. #3478
    Join Date
    Nov 2014
    Posts
    1,275
    Quote Originally Posted by PMRx View Post
    Did not tap it. They are old Rosignol T3 Tele skis. Couldn't find much info. Looked like some metal when I drilled them.

    Mounting speed turns and it's just one heel piece that's a problem. Am I reading that maybe the threading on the heel piece is contributing?
    I'm wasn't sure if a screw could be pulling up a metal sheet/plate without creating a visible volcano. But yeah, if the heel is threaded, sounds like chupacabra is on the right track.

    If there is a thread channel already established in the hole in the ski, and if the screw has no freedom to rotate in the binding hole without advancing (due to being threaded), then it will lift the binding heel just slightly as the screw threads take a moment to line up with the threads in the hole. Conversely, if you clamped it in this situation, you'd just ream out the existing threads and have a nice spinner to show for it.

    All of the above spoken authoritatively, but based only on imagining your issue in my mind's eye. Take it with according number of grains of salt.

    Sent from my SM-G955U using Tapatalk

  4. #3479
    Join Date
    Feb 2012
    Posts
    71
    Agreed, drill the holes out on the bindings until the screws spin freely in the binding holes. This is a common issue on older Dynafits, and also on the rear two holes of Tyrolia Attacks.

  5. #3480
    Join Date
    Jan 2020
    Posts
    3
    Cleaned out the bindings holes. Problem solved. Thank you all.

  6. #3481
    Join Date
    Sep 2008
    Location
    Seattle
    Posts
    623
    Mounted my own fuckin skis last night.
    191 k2 mindbender 99ti with p18 on the line.
    Drilled, tapped & epoxied.
    Hoping these are a solid daily PNW driver for non pow days.

  7. #3482
    Join Date
    May 2017
    Location
    Zurich, Switzerland
    Posts
    349
    Quote Originally Posted by HHTELE View Post
    Originally Posted by PMRx View Post
    For the life of me I can't get my binding to sit flush on the ski. Trimmed the small volcano with a chisel. Sits flat until I get a couple of turns in then it lifts up just a touch. Can't keep it flush with finger strength, should I clamp it? Still seems like an indication something is up.

    Advice?

    Quote Originally Posted by LeoK View Post
    Advice: don't worry too much (at least if the gap is sub .5mm or so). Make sure to seal all screws properly.
    Not sure I agree with this.
    If it sat flush, then moved, it will move more. And, depending on how you ski, leverage on a tele binding can be considerable.

    I must have been quite tired when reading the problem description. If it moves this might indeed be an issue but than I can not really help.
    Take some photos (before and after, and of the ski without the binding) and lets see if somebody has an idea!

  8. #3483
    Join Date
    Sep 2018
    Posts
    783
    Quote Originally Posted by pyromaniacman129 View Post
    Mounted my own fuckin skis last night.
    191 k2 mindbender 99ti with p18 on the line.
    Drilled, tapped & epoxied.
    Hoping these are a solid daily PNW driver for non pow days.
    Like

    Sent from my I3123 using Tapatalk

  9. #3484
    Join Date
    Jul 2005
    Posts
    1,060
    Mounted some Wildcat 108s last night. Besides getting the toes to slide on (got there but not easy) everything went well.
    Click image for larger version. 

Name:	Wildcats.jpg 
Views:	50 
Size:	758.8 KB 
ID:	311200

  10. #3485
    Join Date
    Jan 2011
    Location
    Calgary, Alberta
    Posts
    323
    Quote Originally Posted by rudy View Post
    Mounted some Wildcat 108s last night. Besides getting the toes to slide on (got there but not easy) everything went well.
    Click image for larger version. 

Name:	Wildcats.jpg 
Views:	50 
Size:	758.8 KB 
ID:	311200
    Love those graphics. They look good with the white Shift too.

  11. #3486
    Join Date
    May 2016
    Posts
    795
    My son wripped the rear binding out of a 123 line park ski. Found the ski and binding. Screws just spin the holes. Just epoxy them in? Or redrilling for fresh holes. Second mount. I could find fresh meat for drilling... I think.
    Second pair of skis this has happened. The other pair lost in the woods because brake attached to rear binding and ski shot into woods and lost.
    I can't tell him to not butter. He's 10.
    I was going to just epoxy. They will not be remounted. Ever.

    Sent from my SM-G960U1 using Tapatalk

  12. #3487
    Join Date
    Feb 2008
    Location
    Reno, NV
    Posts
    178
    Quote Originally Posted by jhyatt View Post
    My son wripped the rear binding out of a 123 line park ski. Found the ski and binding. Screws just spin the holes. Just epoxy them in? Or redrilling for fresh holes. Second mount. I could find fresh meat for drilling... I think.
    Second pair of skis this has happened. The other pair lost in the woods because brake attached to rear binding and ski shot into woods and lost.
    I can't tell him to not butter. He's 10.
    I was going to just epoxy. They will not be remounted. Ever.

    Sent from my SM-G960U1 using Tapatalk
    Helicoil/insert or fresh holes...
    Evidently the plastic inserts are actually stronger than the metal!?


    Sent from my SM-G975U using Tapatalk

  13. #3488
    Join Date
    Oct 2007
    Location
    Fort Collins
    Posts
    140
    Quote Originally Posted by jhyatt View Post
    My son wripped the rear binding out of a 123 line park ski. Found the ski and binding. Screws just spin the holes. Just epoxy them in? Or redrilling for fresh holes. Second mount. I could find fresh meat for drilling... I think.
    Second pair of skis this has happened. The other pair lost in the woods because brake attached to rear binding and ski shot into woods and lost.
    I can't tell him to not butter. He's 10.
    I was going to just epoxy. They will not be remounted. Ever.

    Sent from my SM-G960U1 using Tapatalk
    Helicoil/Binding Freedom or remount. Doubt there's any metal, but tap the ski if there is.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •