Results 1 to 10 of 10
  1. #1
    Join Date
    Jun 2006
    Location
    SF
    Posts
    347

    Question for Mac junkies

    My friend just bought a new iPod and it wouldn't work. I looked at it and she ran into a problem because it requires iTunes 8 which in turn requires OS X 10.4 (tiger). She is using an old PowerBook G4 and hasn't upgraded since she got the computer and is running 10.3.9.

    I tried to install Snow Leopard in it when I upgraded my MacBook but she doesn't meet the RAM requirements (not even close, req 1gb and it has 768mb).

    So, any recommendations for getting iTunes to work? Does anyone have an old copy of 10.4 lying around their man cave?

    Thanks
    Progress isn't made by early risers. It's made by lazy men trying to find easier ways to do something.

  2. #2
    Join Date
    Mar 2007
    Location
    Weed, CA
    Posts
    56
    Snow leopard won't work because it's only for intel based processors.
    Did you check the downloads section of apples website?

  3. #3
    Join Date
    Feb 2008
    Location
    Sunnyvale, CA
    Posts
    1,357
    Leopard should work on her system. That is the newest OS that supports PPC based systems, like her PowerBook G4.

  4. #4
    Join Date
    Mar 2008
    Location
    [a] Van [down by the river]
    Posts
    1,235
    I have a retail copy of 10.4 for PPC laying around somewhere in my house. If I find a blank disc, I'll make a copy and send it your way.

  5. #5
    Join Date
    Sep 2008
    Posts
    9,194
    there are some mods to fool the installers into thinking you have X ram, X processor speed etc.
    .....I hope you know that this will go down on your permanent record

    http://procatinator.com/?cat=80

  6. #6
    Join Date
    May 2002
    Location
    Huh?
    Posts
    10,938
    Here are the system requirements for Leopard:

    Processor must be any Intel, PowerPC G5 or G4 (867 MHz and faster)
    DVD drive (for installation of the operating system)
    At least 512 MB of RAM (additional RAM (1 GB) is recommended for development purposes)
    At least 9 GB of disk space available.

    That said, Tiger was a great OS. Huge step up from 10.3.x.
    "I knew in an instant that the three dollars I had spent on wine would not go to waste."

  7. #7
    Join Date
    Sep 2008
    Posts
    9,194
    you don't need a disk drive if you have it on an external and carbon clone it, i guess it all depends on how badly you want it.
    .....I hope you know that this will go down on your permanent record

    http://procatinator.com/?cat=80

  8. #8
    Join Date
    Nov 2007
    Location
    MT
    Posts
    890
    snow leopard was the first OS that required an intel core...leopard will work, snow leopard wont. 10.4 is your best bet.

  9. #9
    Join Date
    Jan 2009
    Posts
    108
    10.4 is slower than than 10.3 on older G4 machines. I upgraded for similar reasons, but it is definitely not optimized for older machines and she will probably noticed some loss of speed when entering text into dialog boxes, etc. If she can find a work around I would definitely advise it.

  10. #10
    Join Date
    Jun 2006
    Location
    SF
    Posts
    347
    Thanks for the advice.
    Progress isn't made by early risers. It's made by lazy men trying to find easier ways to do something.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •